Installation Issues

Jan 5, 2010 at 9:03 PM

Hi there,

I am having some problems trying to make your application work. I followed the instructions and compiled the solution without problems but I am not going anywhere than the error page. This is the extract from elmah:

Host Code Type Error User Date Time
host 404 Http Path '/Views/_Content/img/logo.png' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/img/logo.png' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/css/site.less' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/css/jquery.autocomplete.css' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/css/site.less' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/css/jquery.autocomplete.css' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/css/openid.css' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/css/reset.css' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/css/reset.css' was not found. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/css/openid.css' was not found. Details…   05/01/2010 16:51
host 0 Handler Can't create component 'WhoCanHelpMe.Tasks.NewsTasks' as it has dependencies to be satisfied. WhoCanHelpMe.Tasks.NewsTasks is waiting for the following dependencies: Services: - WhoCanHelpMe.Domain.Contracts.Services.INewsService which was not registered. Details…   05/01/2010 16:51
host 0 Handler Can't create component 'WhoCanHelpMe.Tasks.NewsTasks' as it has dependencies to be satisfied. WhoCanHelpMe.Tasks.NewsTasks is waiting for the following dependencies: Services: - WhoCanHelpMe.Domain.Contracts.Services.INewsService which was not registered. Details…   05/01/2010 16:51
host 404 Http Path '/Views/_Content/img/logo.png' was not found. Details…   05/01/2010 16:47
host 404 Http Path '/Views/_Content/img/logo.png' was not found. Details…   05/01/2010 16:47
host 404 Http Path '/Views/_Content/css/reset.css' was not found. Details…   05/01/2010 16:47

I am using IIS 6.0 (configured as required) on Windows 2003 R2 64bit.  Am I missing something?

Best Regards,

fromano2802

Developer
Jan 6, 2010 at 9:44 AM

Hello - 

Great timing - I have been encountering this same issue for the last 2 days!! I've created an issue for this in the Issue Tracker and am just about to check in the fix....

Its issue #9932 if you want the details.

 

Cheers

James

Jan 6, 2010 at 3:44 PM

Hi James,

Thank you for the fix. It works, but... I still get this:

Host Code Type Error User Date Time
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/img/logo.png' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/img/logo.png' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/css/openid.css' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/css/site.less' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/css/reset.css' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/css/openid.css' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/css/site.less' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/css/jquery.autocomplete.css' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/css/reset.css' was not found. Details…   06/01/2010 11:40
IFATHOM-119 404 Http Path '/whocanhelpme/Views/_Content/css/jquery.autocomplete.css' was not found. Details…   06/01/2010 11:40

If I don't specify the wildcard mapping, I can see browse through the files but I can't run the MVC app.
Let me know what I should do.

Thanks

fromano2802

Developer
Jan 6, 2010 at 7:28 PM
Hi,

From your passing comment about the wildcard mapping, would I be correct in saying you're trying to run the app on IIS6?

Cheers
Jon
Jan 6, 2010 at 7:36 PM

Hi Jon,

good timing! I was jus table to make it work. For IIS6 I had to modify the web.config inside the Views folder:

 

<?xml version="1.0"?>
<configuration>
  <system.web>
    <httpHandlers>
      <add path="*.spark" verb="*"
          type="System.Web.HttpNotFoundHandler"/>
    </httpHandlers>

    <!--
        Enabling request validation in view pages would cause validation to occur
        after the input has already been processed by the controller. By default
        MVC performs request validation before a controller processes the input.
        To change this behavior apply the ValidateInputAttribute to a
        controller or action.
    -->
    <pages
        validateRequest="false"
        pageParserFilterType="System.Web.Mvc.ViewTypeParserFilter, System.Web.Mvc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
        pageBaseType="System.Web.Mvc.ViewPage, System.Web.Mvc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
        userControlBaseType="System.Web.Mvc.ViewUserControl, System.Web.Mvc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
      <controls>
        <add assembly="System.Web.Mvc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" namespace="System.Web.Mvc" tagPrefix="mvc" />
      </controls>
    </pages>
  </system.web>

  <system.webServer>
    <validation validateIntegratedModeConfiguration="false"/>
    <handlers>
      <!-- <remove name="BlockViewHandler"/>
      <add name="BlockViewHandler" path="*" verb="*" preCondition="integratedMode" type="System.Web.HttpNotFoundHandler"/> -->
    </handlers>
  </system.webServer>
</configuration>

 I hope this helps,

fromano2802